8. СОВЕТЫ ПО ИГРЕ

Предчувствуя тот ряд вопросов и трудностей, которые могут встретиться Вам, я решил сделать небольшой FAQ (часто задаваемые вопросы).

Техническая сторона

Вопрос: Я не могу начать новую игру! После нажатия на кнопку «ГОТОВО» введённое имя стирается, а фокус указателя переходит на поле ввода имени.
Ответ: Игра не начинается из-за того, что во вводимом имени игрока присутствует один или несколько запрещённых символов: < > &

Вопрос: Я запускаю игру... А что делать дальше?!
Ответ: Дальше не надо делать ничего. Вы просто читаете игру, то есть интерактивную книгу там, где основная часть текста, смотрите иллюстрации, разглядываете инвентарь и окно персонажа, листаете записную книжку. А потом выбираете какой-то ответ или действие под основной частью, то есть текстом. Затем получаете новую порцию, читаете... И т.д.

Вопрос: Где настройки музыки и цвета шрифта в самой игре?!
Ответ: В процессе игры изменить эти настройки нельзя. Надо выйти в меню (при необходимости предварительно сохранившись) и изменить настройки там.

Вопрос: Я отключаю музыку в опциях, но в меню она продолжает играть.
Ответ: После отключения надо перезапустить меню (начать игру после чего выйти обратно в меню, либо закрыть игру совсем, и снова запустить её).

Вопрос: Ранее упоминалось про записную книжку, инвентарь и окно персонажа. Где мне найти это всё?
Ответ: Справа от основного окна с текстом под изображением динамика есть две кнопки: улыбающаяся рожица обозначает окно персонажа, а рюкзак - инвентарь. Кнопку, вызывающую автозаполняемую записную книжку, ищите ниже. При наведении все кнопки должны «загораться».

Вопрос: При нажатии на предмет в инвентаре появляется только подпись к нему. А как же его использовать?!
Ответ: Непосредственно в инвентаре предметы не используются. При их наличии открывается какая-то диалоговая ветка или вариант к действию, скрытый для Ваших глаз, если предмета нет.

Вопрос: В записной книжке не все записи доступны, однако их названия видно. Это как так?
Ответ: Всё правильно, книжка заполняется сама по мере прохождения игры. Если Вы не дошли до определённого места, не поговорили с кем-либо, то и соответствующая запись не доступна к прочтению.

Вопрос: Можно ли как-то загрузить повреждённое сохранение игры?
Ответ: Нет, повреждённый файл восстановлению не подлежит. Более того, файл, соответствующий повреждённому слоту, необходимо удалить. В худшем случае слот для сохранения и загрузки станет непригодным.

Вопрос: У меня старый компьютер, и игра сильно тормозит. Что можно предпринять?
Ответ: Попробуйте закрыть все неиспользуемые программы, открытые в данный момент. Могут также помочь отключение музыки в опциях игры и перезагрузка компьютера (если он давно включен).

Вопрос: Прокручивание текста при помощи колёсика мыши не получается. Почему?
Ответ: Текст великолепно прокручивается и колёсиком, если указатель мыши находится над областью прокручивания, то есть, помещён в окошко с прокручиваемым текстом.

Вопрос: В процессе игры мне попался заблокированный вариант действия/ответа. Игра дальше не «идёт»?
Ответ: Если вариант недоступен, значит у Вас нет необходимых сведений или предмета. Попробуйте другие доступные варианты. В единственном в игре случае вариант выделен красным (тот, где можно согласиться помочь деревне). Этого варианта нет вовсе, но есть на него намёк :).

Вопрос: Весь текст написан одним человеком? Нет никаких заимствований, цитирований и вставок из чужих произведений?
Ответ: Весь текст писался одним человеком - мной. При написании, никаких заимствований, цитат и вставок я не делал.

Вопрос: В некоторых локациях картинка не сменяется, однако местоположение героя или события изменились. Это специально так?
Ответ: Нет, конечно. Если где-то не хватает иллюстрации, значит я просто не мог её подобрать.

Игровой процесс

Вопрос: Почему я так часто умираю в процессе игры?!
Ответ: Необдуманные поступки и ответы персонажам игры могут привести к гибели. Неадекватные летальные исходы задуманы, но, как правило, и тут к смерти главного героя ведёт неправильная последовательность действий.

Вопрос: Зачем нужны деньги? Они практически нигде не используются!
Ответ: Изначально планировалась развёрнутая торговля с персонажами. Но идея провалилась, а деньги остались.

Вопрос: А зачем же тогда нужен уровень жизни персонажа?
Ответ: В демо-версии был интерактивный бой, где уровень жизни уменьшался от выстрелов. В полной версии такого боя нет, но показатель жизни изредка меняется.

Вопрос: Некоторые предметы не используются. Например, счётчик Гейгера или карта Джимми, которая теряется. Зачем они?
Ответ: Для показателя того, что они есть. Либо про эти предметы идёт речь в тексте.

Вопрос: Что делать, если не все записи в записной книжке для меня открылись?
Ответ: Проходить игру ещё, как минимум, один раз. Сразу стоит отметить, что многие записи могут ещё и меняться со временем.

Вопрос: Я уже получал в тексте уведомление о новой записи в книжке. Почему об одной и той же получил снова?
Ответ: Это означает, что запись была изменена.

Вопрос: Может ли игра зайти в тупик?
Ответ: Нет. Главный герой может умереть, но тупиковых или непроходимых мест в игре нет.

Вопрос: Сюжет игры противоречит Fallout 2.
Ответ: Ещё раз хочу обратить Ваше внимание на то, что моя игра написана не по сюжету, а по мотивам Fallout. Я не задавался целью соответствовать чьему-то сюжету. Считайте это альтернативным развитием событий.

Вопрос: Иногда деревенщины говорят сложными и научными словами. Они же необразованные, как такое может быть?
Ответ: Всё просто. Стершее поколение жителей Шейди Сэндс пришло в деревню из Убежища 15. Подразумевается, что в убежище были специальные обучающие фильмы. Так что их образование почти не отличается от нашего. А вот те, кто родился уже в деревне, у них Вы такие сложные фразы едва ли встретите.


7. АВТОР

Ну, вот и мой любимый раздел :). Шучу, конечно, но без него я бы игру не выпустил в свет. Подробнее обо мне Вы сможете прочитать в самой игре, если, конечно, будете внимательно читать... В общем, есть тайна, которая откроется лишь тогда, когда мрак вечности накроет судьбу главного героя... Удачи!

Но и здесь просто грех кратенько не рассказать о себе. Меня зовут Зыков Иван Андреевич a.k.a. ZEVS, родом я из города Кирова (a.k.a. Вятка), что в Кировской области. День рождения - 24 октября 1988 года. На момент, когда игра вышла «в люди», мне было 17 лет.

Я буду очень рад, если получу от Вас письмо. Пишите на адрес: firstway@rambler.ru, также заходите на домашнюю страничку: http://libertywriter.narod.ru и присылайте сообщения на номер ICQ: 230-223-946. Лучше, конечно, пишите письма!

Ну, и, будучи предусмотрительным, также решил предоставить Вам возможность более щедро отблагодарить меня, нежели просто письмом :). При желании Вы можете поделиться лишними рублями, сделав перевод любой суммы на мой счет в Сбербанке России. Вот реквизиты, необходимые для этой операции:

Лицевой № счёта 42307.810.2.2732.4202772 в филиале № 0130 городского отделения № 69 Сбербанка РФ г. Кирова (ул. Производственная, 19) на имя Зыкова Ивана Андреевича.

Ваши вклады будут в надёжных руках! :)

Благодарности

• Blackman давал дельные советы по программированию на DHTML, за что выражаю ему свою признательность! Когда я только начинал создавать игру, в веб-языках мало что понимал. И поэтому часто спрашивал его, как и что делать. Более того, он по моей просьбе написал программу-конфигуратор для интерфейсной настройки полноэкранного режима (см. раздел «Конфигурация»). Но и это ещё не всё! Он также был бета-тестером и проверил на ошибки около 70 килобайт текста.

• Кланяюсь Jochua за терпение к моим капризам :). Этот человек нашёл в себе силы написать на C++ оболочку для DHTML движка, благодаря которой игра выглядит, как полноценная exe-программа. Да ещё и сделал в точности так, как я это описывал (должен сказать, «описывалась» игра долго, так что ему приходилось постоянно что-то переделывать)!

• Рева Алексей написал саундтрэк для меню игры. Ты классный чувак :) и великолепно играешь как на пианино, так и на гитаре и барабанах! Спасибо, желаю творческих успехов тебе и твоей группе «Iron Sky».

• Спасибо Macbeth'у, как потрясающему тестеру! Всего им было проверено около 100 килобайт текста из полной версии игры. И найдено множество самых разных ошибок. Молодец!

• Ну, и всем-всем-всем, кто поддерживал морально, придавал сил для написания и просто ждал игру - всем вам спасибо!

Авторское право и совесть обязывают меня так же указать студию Black Isle (создатели Fallout), как носителя личных прав на некоторую часть интерфейса игры.

Почти все иллюстрации, сопровождающие текст, взяты из галереи. Назвать их авторов я не могу по причине невладения информацией.

Использованная музыка

• Iron Sky - Stone of Shady Sands OST - саундтрэк к игре.
• Hans Zimmer - Mia's Lullab - тема Шейди Сэндс.
• Depeche Mode - Introspectre - тема Тёмного Братства.
• Shi-Zhi-You - Queen of the Blossoms - тема «у автора в гостях».
• Из игры Nox взята музыка для пустыни и боя.
• Из игры Age of Empires III взята музыка для смерти персонажа.
• Из игры Петька и ВИЧ взята музыка для подземелий.


 Зыков «ZEVS» Иван © 2004-2006


5. КОНФИГУРАЦИЯ

В одной папке с игрой находится файл «config.exe» (конфигуратор). Этот файл позволяет активизировать и гибко настраивать полноэкранный режим игры. Прежде, чем делать это, внимательно прочитайте документацию.

Все настройки сохраняются в файле «soss.cfg» в виде ключей. Изменять его не стоит вообще, за исключением тех случаев, когда конфигуратор утерян, либо не работает должным образом.

Настройка

Режим. По умолчанию игра запускается в оконном режиме. Для активации полноэкранного установите галочку «Полноэкранный режим». После её установки остальные настройки будут доступны. За переключение режима в файле «soss.cfg» отвечает ключ fsmode (0 - выключено; 1 - включено).
По умолчанию: 0.

Разрешение. В окошке выводится список всех поддерживаемых разрешений Вашей видеокартой. Все режимы меньше 800x600 имеют серый цвет, это значит, что ставить их нет смысла - игра окажется «обрезанной». За ширину и высоту отвечают два ключа (соответственно): fswidth и fsheight.
По умолчанию: 800x600.

Глубина цвета. Чем больше значение, тем лучше. Крайне не рекомендуется устанавливать 8 бит. Если какой-то вариант заблокирован, значит, он не поддерживается видеокартой при выбранном разрешении (или не поддерживается вовсе). Глубина цвета хранится в ключе fsbits.
По умолчанию: 16 бит.

Частота обновления экрана. В принципе, любой современный монитор поддерживает хотя бы 85, больше для Ваших глаз и не надо. Но если Вы не уверены в том, какое значение следует вводить, то попробуйте установить «Определять автоматически». В этом случае игра сама подберёт максимально допустимое для видеокарты значение (перебор делается до 85). Но возможности монитора во внимание не берутся. То есть если монитор поддерживает только 60, то следует ввести вручную именно это значение.
Ещё один способ - ввести значение «0», тогда ОС Windows сама подберёт оптимальную частоту (чаще всего это бывает та, что установлена в настройках Рабочего стола).
Частота обновления хранится в ключе fsfreq. По умолчанию: 60.
Настройка автоматического определения управляется ключом fsfmax (0 - выключено; 1 - включено). По умолчанию: 0.

Список режимов. Данная кнопка позволяет просмотреть список всех полноэкранных режимов, поддерживаемых Вашей видеокартой. Удобно для определения нужной частоты обновления экрана.

Примечания

1. Если Вы выбрали разрешение меньше 800x600, о чём при попытке сохраниться конфигуратор предупредил Вас, следует нажать «Отмена». Изменённые настройки сохранены не будут.

2. Список с вручную устанавливаемыми частотами обновления экрана в отличие от разрешений не берётся из списка поддерживаемых режимов. Он стандартен для всех систем. Будьте внимательны при установке частоты вручную!

3. Если Вы не сохранили изменённые настройки экрана кнопками «Сохранить» или «Сохранить и запустить игру», то при закрытии конфигуратора они и не сохранятся!


2. ДИСТРИБУТИВ

Дистрибутив (инсталлятор, установщик) с игрой носит имя «soss_install.exe». По умолчанию игра устанавливается в папку «Program Files\Stone of Shady Sands - First Way\». В установленной папке должны содержаться следующие файлы:

config.exe (34,0 КБ) - конфигуратор для удобной настройки полноэкранного режима. Все подробности в документации.

music.dll (7,03 МБ) - файл с музыкой. Имеется в наличие только в том случае, если у Вас версия дистрибутива игры с музыкой. В противном случае файл отсутствует.

questions.chm (12,7 КБ) - анкета с вопросами для игроков. Если Вы ответите на неё, то автор будет этому очень рад! Надеюсь, подробно, мне ведь хочется получить достойную анкету! Это будет щедрым «подарком» взамен двум с половиной годам, ушедшим на игру.

readme.chm (29,0 КБ) - документация. Её можно прочитать как в этом файле, так и в самой игре, нажав в главном меню на кнопку «Об игре». Если Вы скачивали игру с официальных сайтов (см. ниже), то в zip-архиве помимо установочного файла должна быть данная документация.

soss.cfg (234 байт) - файл конфигурации. Для настройки полноэкранного режима следует использовать конфигуратор (config.exe).

soss.exe (1,99 МБ) - запускаемый файл.

Итак, дистрибутив можно взять по одному из нижеприведённых адресов:

http://libertywriter.narod.ru (домашняя страничка автора игры)
http://indat.team-x.ru (InDat Studio, сайт проекта)

Напоминаю, что вариантов дистрибутива два: с музыкой и без неё. Если файл music.dll отсутствует в папке с Вашей игрой, значит у вас версия без музыки.

Также на этих сайтах отдельно распространяются документация (ReadMe), анкета и конфигуратор.

За все копии игры, скаченные не с официальных сайтов, я не ручаюсь. Они считаются пиратскими версиями.


10. СТАТЬЯ ОБ INTERACTIVE FICTION

Данный материал писался для еженедельника «Мегабайт» (г. Киров) и был опубликован в номере 5(225) от 31 января 2005 года. Копирование статьи запрещено.

Предисловие

Что такое Interactive Fiction? Дословно это переводится как «диалоговый вымысел». Это означает, что вся игра - действие, где, как правило, читатель (играющий) выступает в роли главного героя литературного произведения. Но не стоит считать, что IF - это обязательно компьютерная игра. Это совсем не так, ведь в роли главного героя (а это значит хоть как-то влиять на события) читатель может выступать и в обычной печатной литературе, которая имеет своё название - «интерактивная литература».

Эта статья призвана ответить на вопрос, как же выглядят IF-игры (под другим названием - текстовые квесты) и в чём их достоинства и недостатки перед другими жанрами игрового мира.

История зарождения

Одним из главных плюсов текстовых игр является их низкая требовательность к конфигурации компьютера. Текстовый способ представления информации появился раньше других, а это значит, что первая игра однозначно должна была стать именно текстовой.

Это произошло в 1978 году в Стэнфорде. Тогда появилась самая первая настоящая текстовая игра, получившая название «Adventure». Именно так теперь называют целый жанр компьютерных игр. К сожалению, у российских пользователей сложилось не совсем правильное понятие жанра «Приключение» (так с английского переводится adventure). Обычно при слове adventure возникают ассоциации с яркой и красочной ходилкой-бродилкой-собиралкой (Dizzy, Larry, Prince of Persia, Space Quest, Lion King и не один десяток игр по мотивам диснеевских мультиков). Это определение следует понимать более широко. Приключение может быть как текстовым, так и трёхмерным. В современной игровой индустрии под adventure можно понимать даже такие непотопляемые игры-киты, как Morrowind, Fallout, Diablo и т.п. Но эта статья повествует преимущественно о малой, но когда-то значимой части целого жанра adventure - о текстовых квестах (именно о текстовых, основной частью которых является текст).

На западе игры жанра Interactive Fiction очень популярны и по сей день. Об этом говорит огромное количество примеров известных современных игр-книг (Bureaucracy, All Roads, LASH, Worm In Paradise, Emerald Isle, Jewels of Darkness Trilogy). Однако в России они не стали массовым явлением, и встретить такую игру в наши дни довольно сложно. Но примеры так же можно привести: Кукша из Домовичей, Приключение, Авантюрист, Отчаяние, В глубине.

Так что это такое и с чем его едят?!

Квест - это обязательно головоломка, в которой игрок поставлен перед задачей, для решения которой есть несколько способов, но верным является только один. Текст - это литературное произведение, где не менее трудные задачи заведомо решены автором (их нужно только «пройти» поэтапно, без права выбора). А текстовый квест - это грань между тем и тем, это литературное произведение, сочетающее в себе преимущества обоих. Здесь читатель сам добивается решения, пробуя разные способов, поэтому IF-игры считаются своего рода интерактивной компьютерной литературой.

Для чего нужны текстовые квесты? Дело в том, что текстовый квест - это произведение искусства, плод авторской фантазии. Поэтому спрашивать, зачем это нужно так же глупо, как и спрашивать, зачем нужны книги.

Чего только не придумают...

Отдельно стоит поговорить о разновидностях текстовых игр.

«Но ведь это всего лишь текст?!» - заметите вы. Да, как бы странно это ни звучало, но среди текстовых игр можно встретить примеры, совершенно не похожие друг на друга образцы.

Выделяют два основных типа игр.

Игры с ручным вводом. Определённые действия будут выполняться посредством ввода команд с клавиатуры. Команды должны соответствовать описанию локации. Оно может быть либо графическим (иллюстрации + немного текста), либо текстовым (возможно сопровождение маленькой картинкой). Тогда соответственно описанию следует давать команду. Например, в игре описывается природная панорама и перед читателем ставится выбор направления движения. Он набирает на клавиатуре нечто воде «на юг», «идти по горе», «подняться выше», после чего получает новую порцию текста и/или картинку.

Игры такого плана встречаются редко из-за проблем, возникающих при их создании (очень трудно создать хороший синтаксический анализатор - программу, которая находит во введённой фразе ключевые слова и согласно им «принимает» нужное решение). К тому же игроки не испытывают интереса к вводу команд вручную.

Ярким примером может послужить игра «Приключение». В ней используется синтаксический анализатор на ActionScript (Flash). Скачать игру можно по ссылке: http://www.taplap.ru/articles/65/Adv.zip (2.29 Мбайт).

Текстовые игры с вариантами действий и ответов. Более популярная разновидность игр. Если не брать во внимание их «линейность» (текстовые игры вообще абсолютно нелинейными быть не могут), то игры такого плана более интересны по сравнению с играми с ручным вводом команд.

Вполне можно было бы отдельно упомянуть игры, где вариантом действия являются только картинки или иллюстрации. Хороших примеров таких игр, к сожалению, не много. Создать их способны только очень эрудированные сюжетники.

Примером игры с вариантами действий может послужить моя «Stone of Shady Sands». Подробнее с ней можно ознакомиться и скачать по одному из следующих адресов:
http://libertywriter.narod.ru,
http://indat.team-x.ru.

Изюминки, дополнения

Игра, являющаяся только книгой, на сюжет которой игрок влияет своими ответами, быстро надоест. Бесконечное чтение таких игр-книг ничуть не лучше чтения «обычной» печатной литературы. Для того, что бы как-то разнообразить текстовые квесты, авторы часто прибегают к ухищрениям. Тут можно бесконечно фантазировать, так как преимущество электронных книг очевидно: здесь вам и мини-игры (шашки с персонажем, крестики-нолики и прочее), и нелинейные бои, и инвентарь, который в большинстве случаев бывает в зачаточном состоянии. Излюбленным приёмом у игроделов-писателей можно считать всевозможные головоломки (лабиринты, ребусы, загадки). Тут всё зависит от фантазии создателя игры.

Так же к приятным дополнениям можно отнести мультимедиа. Думаю, чтение книги под приятную атмосферную музыку, меняющуюся в зависимости от текста игры, вас только порадует, а яркий курсор или красочный дизайн будут играть свою роль в формировании окончательного мнения об игре.

Кто и зачем делает Interactive Fiction?

Жанр интерактивной компьютерной литературы не мёртв, но стар и немощен перед масштабностью современных «игр-гигантов». Каким бы искусством он (жанр) не считался, текстовые игры уже никогда не увидят своего второго рождения. По этой причине интерактивную литературу, распространяемую за деньги, встретить довольно трудно. А значит - почти всё то богатство, которым мы сейчас распоряжаемся, создано энтузиастами, желающими созидать. Это, в свою очередь, является причиной другой тенденции - большинство текстовых игр выполнены непрофессионально, в целях сделать себе имя, получить опыт или просто убить время на работе.

Ниже вы прочитаете информацию о том, какими способами можно создать свой текстовый квест.

Что и как делать?

Таким вопросом задаются все без исключения, желающие созидать, творить нечто новое. Как известно, для этого всегда необходимо использовать огромный творческий потенциал. А сможете ли вы здраво оценить, хватит ли его для того, чтобы взяться и завершить свой проект?

Второй вопрос - для кого и для чего будете делать вы? Предположим, что цель создания вам ясна, но остаётся понять, нужно ли будет кому-то ваше творение, не будет ли напрасным весь ваш труд?.. Если вы считаете, что способны написать интересный сюжет и готовы не только начать, но и завершить свой проект, то у вас обязательно всё должно получиться!

Как делать. Вопрос, в обязательном порядке требующий ответа. Существует не один десяток программ-редакторов, облегчающих непосильный труд игроделов. Существуют и языки программирования, которые этот самый труд для новичков превращают в ад. Тут я могу лишь посоветовать одно - если вы не программист, не знаете ни одного языка программирования и не знакомы ни с одним из программистов, то ваша дорога одна, и она ведёт в сторону специализированных программ для создания текстовых игр. Таких программ, как было сказано выше, несколько десятков. Но лишь единицы из них достойны вашего внимания.

ADRIFT (Adventure Developer & Runner - Interactive Fiction Toolkit)
Популярная среда разработки. Все версии до 4-ой распространяются бесплатно. Готовые игры имеют расширение .TAF и запускаются при помощи программы Adrift Runner.
В России крупнейшим сайтом по программированию в среде ADFIRT считается «Клуб Адвантюристов».

TADS (Text Adventure Development System)
Не менее популярная среда разработки, требующая некоторых знаний программирования. Абсолютно бесплатная. Готовые игры имеют расширение .GAM и выполняются только TADS-интерпретатором. Существует русская версия TADS, которая имеет другое название - RTADS (Russian Text Adventure Development System). Официальный сайт английской программы - http://tads.org.

Inform
По количеству созданных игр на этой платформе, она самая популярная. К тому же - бесплатная. Имеется возможность создания игр с синтаксическим анализатором, в том числе, на русском языке (необходима русифицированная версия). Официальная страница Inform - http://inform-fiction.org.

Помимо этих программ есть ещё и другие:

• Adventure Game Studio (AGS), для создания игр, как бестселлеры от Sierra Online и LucasArts;
• SCI Studio, позволяющая создавать такие игры, как Space Quest 3;
• AGAST, альтернатива AGS;
• MAD Project, альтернатива SCI Studio;
• AGI Studio, позволяющая делать 16-цветные игры, такие, как Space Quest 1 и King's Quest 1;
• SLUDGE, утилита, для создания простеньких квестов;
• Adventure Maker, программа, для создания квестов от первого лица (подобие RPG);
• 3D Adventure Studio, для создания квестов, похожих на Gabriel Knight 3...

Некоторые люди предпочитают программировать свой собственный движок для текстовых игр. Не думайте, что это просто. Конечно, профессиональный программист способен написать движок за один вечер. У новичка же на изучение языка программирования и получение хорошего результата может уйти несколько недель (как у меня), а то и месяцы.

Если вы всё-таки задумали писать собственный движок, то стоит выбрать, на каком языке. Это может быть какой-нибудь ЯВУ (Язык Высокого Уровня), как C++ или Delphi, может быть Flash или даже HTML и JavaScript. Выбор остаётся за вами.

Советую всем заинтересовавшимся зайти на сайт http://www.taplap.ru - Interactive Fiction по-русски.

Еженедельник «Мегабайт» №5(225)
от 31 января 2005 г.
Иван ЗЫКОВ


1. ВВЕДЕНИЕ

Коротко о главном

Игра представляет собой текстовый квест жанра Interactive Fiction с вариантами действий и ответов. О том, что это за жанр, Вы можете прочитать в статье (см. меню слева). Постъядерный мир создавался по мотивам игры жанра RPG - Fallout. Мне на момент зачатия проекта, к сожалению, не хватило сил и опыта на создание собственной Вселенной.

Stone of Shady Sands (сокр. SoSS) переводится как «Камень Шейди Сэндс». Итак, для тех, кто играл в Fallout, расскажу, что события SoSS происходят спустя несколько месяцев после смерти Мастера и ухода Жителя Убежища на север. Главный герой моей игры - изгнанный уроженец Убежища 8 (которое через 80 лет породит диктатуру Волт-Сити). Главный герой должен помочь жителям деревушки выжить в ночной битве. Но селянам этого недостаточно, ведь им угрожает не просто банда, а неведомая сила, скрываемая ими же самими...

Название First Way подразумевало, что эта игра - лишь часть чего-то грандиозного. Это не так. Вернее сказать, не совсем так. Подобных проектов на базе SoSS я больше делать не планирую, зато начал разработку собственной Вселенной, которая может лечь в основу ещё не одной игры... Но это уже совсем другая история :).

Как это было

Обычной февральской ночью (16-ого числа) 2004-ого, когда улицу за окном уже покрывал зимний мрак, вдохновлённый Fallout сидел пятнадцатилетний парень за монитором и что-то ускоренно строчил в текстовом редакторе. Сейчас уже никто не помнит, что именно он набивал на приобретённой менее полугода назад машине на замену старой, но именно тогда родилась в голове замечательная идея - сделать текстовый квест!

Спустя недели кропотливой работы, был создан первый прототип кое-как работающего DHTML-движка. Но то, что существовало в те дни, являлось чем-то между паровым утюгом на углях и ламповым телевизором... Написанный полностью на DHTML движок работал крайне медленно и с жёсткими ограничениями. Что касается текста, на тот момент его не было. Но вопреки всему, удалось заставить pre-альфа-версию работать...

Шли месяцы, писались тексты, строились на фундаменте Fallout графические элементы, музыка, иллюстрации, однако далёкий от безупречности по сегодняшним меркам движок претерпевал лишь косметические преобразования. За исключением новых «фишек», как сохранение игры, загрузка, ввод имени в начале и т.п. Всё это могло работать только при помощи включённых в настройках Cookies. Это новое условие ещё более сузило количество людей, которые должны были играть в квест. Уже тогда я мечтал о более полноценном движке на ЯВУ (Язык Высокого Уровня). Моим мечтам не было суждено сбыться.

Хотя...

В октябре 2004 г. я принял решение заручиться небольшой помощью со стороны. В прочем, не многое изменилось внутри моего DHTML-движка. Но оболочка для игры на базе браузера MSIE, написанная Jochua, решила несколько проблем. Самое главное, мне не пришлось (а рано или поздно это случилось бы) проектировать новый скриптовый движок, или даже DirectX-овый.

В период с 29 октября по 15 декабря 2004 г. движок со своей новой оболочкой окончательно (для демо) покрылся шоколадом и сливочной глазурью :). И уже 25-го декабря того года, как и обещал («в этом году...»), игра Stone of Shady Sands - demo version вышла в свет! Результат был умопомрачительным! В первый же день была исписана не одна страница на форумах, а на адрес e-mail мне пришли первые плоды сего творения!

За первый месяц пришло несколько десятков ответов на анкету (присутствует в архиве с игрой) и просто писем. За этот первый месяц я не понаслышке узнал, что такое слава (хоть и довольно в узких кругах) и подпитка для энтузиазма. Но самое «мясное» меня ещё ожидало...

Знаменательным событием стала публикация игры на одном из дисков, прилагаемых к журналу «Игромания». Это было нечто! Представляете моё лицо, когда, специально купив журнал, я всё-таки нашёл там свою игру! То был мартовский 90-ый номер (2005-ого года), появившийся в продаже 5-го числа. Месяцем раньше, не получив ответа от редакции, я уж и не надеялся увидеть там свой проект, а вернее, его демо-версию.

В течение всего марта, особенно первой половины, каждый день приходилось проверять электронную почту, чтобы ответить на письма! С тех пор печатаю быстрее, чем пишу шариковой ручкой по бумаге :).

За год, что прошёл с момента публикации игры на диске журнала, было многое изменено, испытано, внесено или уничтожено безвозвратно. Так, например, карта текущей локации была создана, прожила около полугода и умерла. А информационный блок ПИП-боя (нечто вроде карманного ПК) ждала та же участь, но в большей степени, так как от него мне пришлось отказаться, когда уже было почти всё сделано. О причинах я уже ничего не помню. Разве что надоело возиться :).

Изначально в квесте планировались две концовки. Первая (и основная) - герой соглашается помочь деревне и отправляется за помощью в ближайшее убежище. Вторая концовка - главный герой отказывает в помощи и уходит в пустыню, за новыми приключениями. Но когда я только-только приступил к написанию текстов для второй концовки (а начал именно с неё), понял, что задуманные масштабы мне не потянуть. Тогда я остановился на втором варианте прохождения :). Но он построен таким образом, что приключения главного героя всё равно составляют полноценный сюжет.

В течение двух лет параллельно написанию текстов, я переделывал движок демонстрационной версии. И вот, 31 августа 2006 года полная версия игры, разрабатывающейся 2 года 7 месяцев и 15 дней, вышла в свет. Обо всех её преимуществах перед большинством игр этого жанра Вы прочитаете ниже.

Особенности игры

• Многослотное сохранение с возможностью комментирования;
• выбор цвета текста (зелёный/жёлтый);
• инвентарь;
• окно персонажа;
• автозаполняемая записная книжка;
• здоровье и деньги.

• Огромное количество текста (более 200 килобайт);
• разветвления в сюжете;
• соответствие текста «духу» и атмосфере постъядера.

• Широкие мультимедиа возможности;
• анимация всех активных элементов интерфейса;
• иллюстрации к текущей игровой сцене;
• семь саундтрэков для локаций.


 1. Введение
 2. Дистрибутив
 3. Возможные проблемы
 4. Системные требования
 5. Конфигурация
 6. Лицензия
 7. Автор

 8. Советы по игре
 9. Прохождение
10. Статья об IF


6. ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ

Здесь и далее под словом «игра» понимается данная игра - «Stone of Shady Sands: First Way».

1. Все авторские права принадлежат их законным владельцам (см. раздел «Автор»).

2. Игра не несёт в себе деструктивного кода, но, тем не менее, принимая эту лицензию, Вы соглашаетесь с тем, что будете использовать игру на свой страх и риск, а автор не несёт какую-либо ответственность за любой вид ущерба, нанесённого её использованием.

3. Любое частное лицо имеет право использовать данную копию игры бесплатно в некоммерческих целях в течение неограниченного срока с момента первого запуска. Игра распространяется свободно, но ни одно частное лицо или организация не может брать плату за её распространение. Публикация игры на компакт дисках строго запрещается!

4. Вы не имеете права создавать новые версии игры или разрабатывать свою на основе данной, не имеете права изменять, изучать и использовать код игры в своих целях. Распространяемый архив должен оставаться неизменным. Любое подобное нелегальное использование означает нарушение настоящего соглашения и может преследоваться по законам «Об авторском праве и смежных правах» и «О правовой охране программ для электронных вычислительных машин и баз данных».

5. Использование игры означает, что Вы ознакомились с настоящим лицензионным соглашением и согласны со всеми его условиями.

6. Если почему-либо Вы не согласны с этим лицензионным соглашением, удалите все файлы игры с ваших устройств хранения информации и немедленно прекратите её использование.


3. ВОЗМОЖНЫЕ ПРОБЛЕМЫ

• В Windows 95 игра будет идти некорректно или вообще не заработает! Советую запускать её под Windows 98 и более новые версии.

• Вместо музыки Вы можете услышать скрежет и вопли (или что-то ещё). Скорей всего нет необходимого декомпрессора.

• На время работы игры отключайте блокираторы рекламы и всё прочее, что может запрещать всплывающие окна.

• Если текст игры отображается в непонятной кодировке (начиная с главного меню), то уберите (или, наоборот, попробуйте поставить) в настройках Internet Explorer галочку «автовыбор» (Вид -> Кодировка).

• Файлы сохранения «game[1-6].svg» и конфигурации «config.svg» при попытке изменения вручную будут повреждены. В таком случае необходимо повреждённый(-ые) файл(-ы) удалить, иначе игра не будет иметь к ним доступ.

• Запустив игру в оконном режиме, но с разрешением рабочего стола 800x600, жёлтые краешки окажутся обрезанными. Это никак не вредит игровому процессу, но приятнее для глаза будет запускать игру в полноэкранном режиме с аналогичными настройками.

• Если при запуске в полноэкранном режиме появилось уведомление об ошибке неправильного режима экрана (например, «Invalid fullscreen mode: 1024X768X32bppX59hrz»), и игра запустилась в окне, то для корректной работы необходимо изменить настройки таким образом, чтобы ошибка исчезла. Или, в худшем случае, отключить полноэкранный режим.

• Если при запуске в полноэкранном режиме экран монитора потух и не подаёт признаков «жизни», либо наблюдается «дребезжание» дисплея, следует установить допустимые (поддерживаемые Вашими монитором и видеокартой) значения разрешения, глубины цвета и частоты обновления экрана. Если ничего не помогло, отключите полноэкранный режим. Напоминаю, что закрыть окно игры и вернуться в ОС Windows можно, нажав Alt+F4 (это на случай, когда ничего не видно).

Если Вы столкнулись с какими-то проблемами, не упомянутыми выше, убедительно прошу известить меня об этом. Возможно, это позволит решить их.


4. СИСТЕМНЫЕ ТРЕБОВАНИЯ

Игровой движок довольно требователен как к Вашему «железу», так и программному обеспечению. Вот минимальные системные требования игры:

Операционная система: Windows 98 или более новая версия
Браузер: Internet Explorer 5.0+
Процессор: Pentium 200 MMX
Оперативная память: 32Mb
Видео: 800x600px, 8 bit
Мышь обязательна. Звуковая карта - нет.

На компьютерах со слабым процессором и недостаточным количеством оперативной (системной) памяти игра будет заметно подтормаживать!


9. ПРОХОЖДЕНИЕ

В игре, как ни странно, присутствуют проблемные места, а также альтернативные варианты прохождения. О них Вы прочитаете ниже.

Внимание! Настоятельно не рекомендую читать прохождение до того, как пройдёте игру хотя бы один раз! Либо читайте только в случае появления трудностей.

Лабиринт

Попав в лабиринт, Вы столкнётесь с трудностями. Пройти его можно, но придётся повозится. Целью здесь является нахождение двух ключей для двери, ведущей к выходу из западни.

Для упрощения я привожу одну из правильных последовательностей выбора действий. Сначала идите к месту старта (туда, где появилась новая запись «лабиринт»). Отсюда делаем всё в такой последовательности:

Северо-восток −> Восток −> Запад −> Север −> Запад −> Север −> Порыться в мусоре −> Юг −> Восток −> Юг −> Восток −> Зацепить монтировкой −> Запад −> Юго-восток −> Северо-запад −> Запад −> Сломать замок монтировкой −> Восток −> Юго-восток −> Северо-восток −> Восток −> Использовать верёвку −> Запад −> Север −> Восток −> Отпереть замки

И всё! Неужели, было сложно проделать это без моей помощи :)?

Кстати, в этих пещерах есть ответ на один незначительный вопрос... Но до вопроса надо ещё додуматься, а ответ на него - найти! Так что, придётся поискать источник бесконечного везения :).

Вагонетка

Альтернативный вариант прохождения взамен лабиринту - это подземная железная дорога, где целью будет заставить ехать старую вагонетку. Текста здесь немного поменьше, но это не менее интересно!

Итак, чтобы пройти вагонетку, необходимо произвести следующую последовательность действий. Точкой отсчёта считайте сектор «железная дорога».

Войти в рубку управления −> Перевести стрелку −> Назад −> Понизить питание на рельсах −> Назад −> Подойти к рельсам −> Назад −> Ступить на борт вагонетки −> Назад −> Войти в рубку управления −> Осмотреть кучу хлама −> Назад −> Назад −> Подойти к рельсам −> Затянуть болты гаечным ключом −> Назад −> Назад −> Ступить на борт вагонетки −> Использовать синтетическую смазку −> Назад −> Назад −> Войти в рубку управления −> Повысить питание на рельсах −> Назад −> Назад −> Ступить на борт вагонетки −> Снять вагонетку с тормоза

И нечего пугаться :). Всё просто, если вчитываться в текст внимательно. Совет: сохраняйтесь перед нажатием на вариант «Снять вагонетку с тормоза», а не то Ваш персонаж рискует умереть здесь аж тремя способами.

Ящичек в столе Отчима

В тёмном Братстве в комнате Отчима (Джулис Мормелианский) стоит стол с закрытым ящиком. Открыть его очень просто: надо использовать ключи в такой последовательности: серебряный, синий, медный.

Если кто не понял, последовательность цветных ключиков образует российский триколор (белый-синий-красный).

Сложность в том, что неправильная комбинация ключей приводит к поломке замка, после чего нельзя будет его открыть. Поможет только загрузка... Но, тем не менее, игра не заходит в тупик, если замок не открыть. Просто Вы не получите некий бонус - вот и всё!

Вход в экстенсивную камеру

Вход в экстенсивную камеру (о том, что это такое Вы прочитаете в записной книжке в самом конце игры) закрыт под паролем. Пароль в обязательном порядке появляется в записной книжке после осмотра трупа Когтя Смерти. Напоминаю пароль: 2261941.

У автора в гостях

Для того, чтобы попасть в секретную комнату, то есть ко мне домой :), необходимо начать новую игру, введя в графу с именем пароль, который Вы вводили (если ещё нет, то Вам это читать нельзя!) при входе в экстенсивную камеру (см. выше). Не забывайте правильно указать пол, он будет нужен!


Stone of Shady Sands: First Way